Announcement

Collapse
No announcement yet.

instrument cluster problems on 2014

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • instrument cluster problems on 2014

    Does anyone have problems and solutions for instrument cluster malfunctions?

  • #2
    I think this may have been chatted about recently...have you tried a search of previous posts?

    Comment


    • #3
      I just searched instrument cluster and I believe there was info about the FEM being the culprit. Try the search. I am assuming you are referring to the retrobird and you meant 2004? (typo?)

      Comment


      • #4
        Yes typo sorry

        Comment


        • #5
          Could you share with us some of the problems you are experiencing with the dash cluster. Maybe some here have had the same & Knon of a fix.
          Mike

          sigpic

          Comment


          • #6
            From my understanding the drive and park light are not working and also the speedometer. He has been chatting with me via PM but I don't have the knowledge base to help him. Any ideas? I read previous posts on refurbishing front electronic modules... could it be something more straightforward and easier to fix? Anyone else have a similar issue and know a solution?
            Last edited by TBird1stLuv; Sep 28, 2018, 05:24 PM.

            Comment


            • #7
              Originally posted by TBird1stLuv View Post
              From my understanding the drive and park light are not working and also the speedometer. He has been chatting with me via PM but I don't have the knowledge base to help him. Any ideas? I read previous posts on refurbishing front electronic modules... could it be something more straightforward and easier to fix? Anyone else have a similar issue and know a solution?
              Run OBD II check. Run the check that tests all modules (not the quick error code check).
              2002 Motor Trend COTY Blue/White/Full #24737 (One of 291)
              2015 Ford Escape Titanium 2.0T 240HP, 270FP Torque
              http://www.thunderbirdnest.com/membe...8&username=hks

              Comment


              • #8
                Are you saying he has no headlights or parking lights or no dash lights?

                Also since the dash lights operate on a built-in daylight sensor they will not appear to be on unless the ambient light is dark.
                Mike

                sigpic

                Comment


                • #9
                  He was not specific other than saying,"The drive or park light does not work and no speedometer". I asked him to refer back to his initial posts since people were asking questions.
                  HKS Thanks for responding. I mentioned that you had a very informative post on replacing your FEM. I hope he checks back in. He was PM me and I am quite limited on telling him anything further than what I read in older posts. Thank you in advance to all willing to chime in and give him some good advice.

                  Comment


                  • #10
                    Thanks

                    Comment


                    • #11
                      Originally posted by HKS View Post

                      Run OBD II check. Run the check that tests all modules (not the quick error code check).
                      https://www.bluedriver.com/

                      Blue driver is the OBD II checker I use. Cost is $99. I use it with iPhone.
                      Look at the website and see if it works with Samsung also.
                      You can download the software for free but you need to buy the module that plugs in to the OBD II port.

                      HKS
                      2002 Motor Trend COTY Blue/White/Full #24737 (One of 291)
                      2015 Ford Escape Titanium 2.0T 240HP, 270FP Torque
                      http://www.thunderbirdnest.com/membe...8&username=hks

                      Comment

                      Working...
                      X